Mail users with iOS and MacOS devices cannot access mail after certificate renewal on the server: Cannot Verify Server Identity

Symptoms

  • Let's Encrypt SSL certificate securing mail has been renewed on the  server.

  • Cannot Verify Server Identity

     

    Settings cannot verify the identity of "mail.example.com". Would you like to continue anyway?

  • In iOS / MacOS mail client there is no "Trust" button on "Details" screen in the upper-right corner.

Cause

iOS / MacOS issue: system does not allow the user to "trust" a SSL/TLS certificate if an already existing mail account is set up with a not certificate by default.

Resolution

There are two possible solutions:

Solution 1. Recreate mail accounts devices

  • Remove mail account from iOS / MacOS device.
  • Re-create email account on iOS / MacOS device.

 Solution 2. Manually install and allow using required SSL certificates from device settings:

  • Get the certificate. The certificate can be exported from the browser to a .cer file:
Click on a section to expand
  • Upload the .cer file on iOS device through email, Safari browser or File Sharing and install it by clicking/tapping on the uploaded file.
  • Set up the email account.
  • If more information is needed on the certificate, it can be found in: Settings > General > Profile.
  • Mailboxes, Mail Services
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